Passa al contenuto principale

Parlando con la gente di SSH ho scoperto che c'è una notevole confusione tra la versione di rilascio e la versione del protocollo.

Stratus ha rilasciato due versioni di OpenSSL/SSH. La release 1 funziona sulla piattaforma Continuum sotto la release 14.7x di VOS. La release 2 funziona sulla piattaforma Vseries con release superiori a 15.0. La differenza principale è che la release 1 non supporta i PTY e richiede l'uso del tunneling per i login interattivi. La release 2 supporta il tunneling ma supporta anche i PTY in modo che il tunneling non sia necessario per i login interattivi.

SSH è disponibile anche in 2 versioni di protocollo, 1 e 2. Queste versioni di protocollo sono indipendenti dalle versioni di rilascio Stratus . Sia la release 1 che la release 2 supportano le versioni di protocollo 1 e 2.

La versione 1 del protocollo ha alcuni problemi di sicurezza noti. Si possono trovare riferimenti sul web che suggeriscono di disabilitare la versione 1. Ancora una volta, questo si riferisce alla versione 1 del protocollo e non alla versione 1 di OpenSSL/SSH. Stratus .

Per disabilitare la versione 1 del protocollo nel server cambiare la direttiva del protocollo nel file >sistema>openssl>etc>sshd_config

da:
#Protocollo 2,1
a:
Protocollo 2.
Si noti che nelle versioni successive di OpenSSL/SSH. versione 1 e nella versione 2 questo è già stato fatto.

© 2020 Stratus Tecnologie.